ThinClient Fujitsu Siemens FUTRO S400 i OpenBSD

Z okazji wydania OpenBSD 5.0, nabyłem drogą kupna terminal Fujitsu Siemens Futro S400 z przeznaczeniem na domowy serwer. Obecnie znajdują się na nim takie usługi jak: DHCP, lokalny DNS, SSH, WWW, SAMBA, FTP, w chwili obecnej urządzenie jest wyposażone w jeden interfejs sieciowy, więc na razie nie będzie ono działało jako ruter, ani Access Point, czego nie wykluczam w przyszłości. System jest zainstalowany na karcie CF, a dodatkowo jest podłączony dysk USB 2.5″ 250GB, na którym znajdują się katalogi /usr, /var/ oraz /home.

Wewnątrz urządzenia znajduje się standardowe złącze IDE 40pin. Używając odpowiedniego adaptera, możemy zainstalować dysk PATA 2.5″, niestety nie posiadam takiego dysku, dlatego też dysk podłączony do portu USB.

OpenBSD zainstalowałem używając Pendrive USB, niestety nie udało mi się uruchomić systemu z zewnętrznego dysku USB 2.5″. Instalację możemy również przeprowadzić używając sieci LAN.

Jednym z ciekawszych rozwiązań jakie możemy znaleźć, to chłodzenie procesora. Ciepło wytwarzane przez procesor jest rozprowadzane po obudowie urządzenia. Innym udogodnieniem jest włączenie i wyłączenie urządzenia za pomocą kombinacji klawiszy Ctrl+Alt+Backspace.

Teraz kilka słów na temat samego urządzenia.

Specyfikacja: ThinClient Fujitsu Siemens FUTRO S400
Procesor: AMD Geode™ NX 1500@6W - 1000MHz
BIOS: Phoenix-Award
Pamięć RAM: 256MB DDR SO-DIMM
Grafika/Chipset: SiS 963L / SiS 741CX
Interfjes LAN: Realtek 8169 10/100/1000 Mbit/s Fast Ethernet PXE
Złącze IDE 40pin
Slot kart CompactFlash
Złącze PCI (maksymalna długość karty to 155mm)
Port LPT
Port RS232
4 złącza USB
Audio In/Out
Wyjście VGA D-SUB
Mysz PS/2
Klawiatura PS/2
Wymiary: 246 x 68 x 177
Waga: około 1,5kg
Zewnętrzny zasilacz 12V, 5.0A (60W)

Zużycie energii
Maksymalne27W
Średnie18W
Minimalne3.8W

Wydruk dmesg

# dmesg
OpenBSD 5.0 (GENERIC) #43: Wed Aug 17 10:10:52 MDT 2011
    deraadt@i386.openbsd.org:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: AMD Athlon(tm) Processor ("AuthenticAMD" 686-class, 256KB L2 cache) 1.01 GHz
cpu0: FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 234352640 (223MB)
avail mem = 220483584 (210MB)
mainbus0 at root
bios0 at mainbus0: AT/286+ BIOS, date 05/14/08, BIOS32 rev. 0 @ 0xfaa30, SMBIOS rev. 2.2 @ 0xf0000 (31 entries)
bios0: vendor Phoenix Technologies, LTD version "6.00PG Rev. 4.00.0Q" date 05/14/2008
bios0: FUJITSU SIEMENS FUTRO S400
apm0 at bios0: Power Management spec V1.2 (slowidle)
acpi at bios0 function 0x0 not configured
pcibios0 at bios0: rev 2.1 @ 0xf0000/0xc794
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfc6f0/144 (7 entries)
pcibios0: PCI Exclusive IRQs: 3 5 9 10 11 15
pcibios0: PCI Interrupt Router at 000:02:0 ("SiS 85C503 System" rev 0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0xc000 0xcc000/0x4000! 0xd0000/0x1000 0xef000/0x1000!
cpu0 at mainbus0: (uniprocessor)
pci0 at mainbus0 bus 0: configuration mode 1 (bios)
pchb0 at pci0 dev 0 function 0 "SiS 741 PCI" rev 0x03
sisagp0 at pchb0
agp0 at sisagp0: aperture at 0xe8000000, size 0x4000000
ppb0 at pci0 dev 1 function 0 "SiS 86C202 AGP" rev 0x00
pci1 at ppb0 bus 1
vga1 at pci1 dev 0 function 0 "SiS 6330 VGA" rev 0x00
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 2 function 0 "SiS 85C503 System" rev 0x25
pciide0 at pci0 dev 2 function 5 "SiS 5513 EIDE" rev 0x00: 741: DMA, channel 0 configured to compatibility, channel 1 configured to compatibility
wd0 at pciide0 channel 0 drive 0:
wd0: 16-sector PIO, LBA48, 57231MB, 117210240 sectors
wd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2
pciide0: channel 1 ignored (disabled)
auich0 at pci0 dev 2 function 7 "SiS 7012 AC97" rev 0xa0: irq 10, SiS7012 AC97
ac97: codec id 0x414c4770 (Avance Logic ALC203 rev 0)
ac97: codec features headphone, 20 bit DAC, 18 bit ADC, No 3D Stereo
audio0 at auich0
ohci0 at pci0 dev 3 function 0 "SiS 5597/5598 USB" rev 0x0f: irq 9, version 1.0, legacy support
ohci1 at pci0 dev 3 function 1 "SiS 5597/5598 USB" rev 0x0f: irq 3, version 1.0, legacy support
ehci0 at pci0 dev 3 function 3 "SiS 7002 USB" rev 0x00: irq 5
ehci0: timed out waiting for BIOS
usb0 at ehci0: USB revision 2.0
uhub0 at usb0 "SiS EHCI root hub" rev 2.00/1.00 addr 1
re0 at pci0 dev 9 function 0 "Realtek 8169" rev 0x10: RTL8169/8110SB (0x1000), irq 15, address 00:90:dc:07:3d:c1
rgephy0 at re0 phy 7: RTL8169S/8110S PHY, rev. 3
isa0 at pcib0
isadma0 at isa0
com0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
spkr0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
wbsio0 at isa0 port 0x2e/2: W83697HF rev 0x12
lm1 at wbsio0 port 0x290/8: W83697HF
npx0 at isa0 port 0xf0/16: reported by CPUID; using exception 16
usb1 at ohci0: USB revision 1.0
uhub1 at usb1 "SiS OHCI root hub" rev 1.00/1.00 addr 1
usb2 at ohci1: USB revision 1.0
uhub2 at usb2 "SiS OHCI root hub" rev 1.00/1.00 addr 1
mtrr: Pentium Pro MTRR support
vscsi0 at root
scsibus0 at vscsi0: 256 targets
softraid0 at root
scsibus1 at softraid0: 256 targets
root on wd0a (6033a1aca10172d8.a) swap on wd0b dump on wd0b

sysctl hw

# sysctl hw
hw.machine=i386
hw.model=AMD Athlon(tm) Processor ("AuthenticAMD" 686-class, 256KB L2 cache)
hw.ncpu=1
hw.byteorder=1234
hw.pagesize=4096
hw.disknames=wd0:8b2f62e6f9ae5c18,sd0:673638487314ab73,sd1:
hw.diskcount=3
hw.sensors.lm1.volt0=0.00 VDC (VCore)
hw.sensors.lm1.volt1=0.00 VDC (+3.3V)
hw.sensors.lm1.volt2=4.97 VDC (+5V)
hw.sensors.lm1.volt3=0.00 VDC (+12V)
hw.sensors.lm1.volt4=-14.91 VDC (-12V)
hw.sensors.lm1.volt5=-7.71 VDC (-5V)
hw.sensors.lm1.volt6=4.92 VDC (5VSB)
hw.sensors.lm1.volt7=3.25 VDC (VBAT)
hw.cpuspeed=1001
hw.vendor=FUJITSU SIEMENS
hw.product=FUTRO S400
hw.serialno=LSD04345
hw.uuid=22428976-3515-2242-3333-00121288ee8g
hw.physmem=251129856
hw.usermem=251117568
hw.ncpufound=1
hw.allowpowerdown=1

Komentarze są wyłączone.